Commit 6617a308 authored by Sören Hentzschel's avatar Sören Hentzschel

Bugfix: fehlerhafte Versionserkennung korrigiert

parent 2eeb9710
......@@ -13,13 +13,14 @@ const simplePrefs = require('sdk/simple-prefs');
const newtaboverride = {
lastClipboardUrl : false,
timer : false,
version : parseFloat(version),
init : function () {
newtaboverride.onPrefChange();
},
override : function (newTabUrl) {
if (version < NEW_API_FIREFOX_VERSION) {
if (this.version < NEW_API_FIREFOX_VERSION) {
require('resource:///modules/NewTabURL.jsm').NewTabURL.override(newTabUrl);
} else {
const { Cc, Ci } = require('chrome');
......@@ -30,7 +31,7 @@ const newtaboverride = {
},
reset : function () {
if (version < NEW_API_FIREFOX_VERSION) {
if (this.version < NEW_API_FIREFOX_VERSION) {
require('resource:///modules/NewTabURL.jsm').NewTabURL.reset();
} else {
const { Cc, Ci } = require('chrome');
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment